Welcome to MCList!

a month agoJoined
Unable to connect to survival: Outdated client! Please use 1.20.2
a month agoBungeeCordJoined
You have to accept the server resource pack in order to play! Visit http://s.moep.tv/rp for info on how to enable it!
a month agoJoined
This server has mods that require FML/Forge to be installed on the client. Contact your server admin for more details.
a month agoJoined
You are not whitelisted on this server!
a month agoCrackedBungeeCordJoined
a month agoJoined
This server requires you to install the Origins mod (v1.10.0) to play.